Erreurs NPM et Grunt

Bonjour,

J’essaie d’installer un projet « docdoku-web-front » qui nécessite nodejs avec grunt et npm.
Quand je lance, dans mon projet, la commande:

npm run dev

j’obtiens des erreurs avec npm et je pense que, dans les dépendances, il me faut 2 versions de grunt. La version 0.4.1 et une version supérieur à 1

Quand je lance la commande pour déployer grunt 0.41 dans mon projet:

npm install --save-dev "[email protected]~0.4.1"

J’obtiens ces erreurs:

npm WARN deprecated [email protected]: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated [email protected]: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN [email protected] requires a peer of [email protected]>=1 but none is installed. You must install peer dependencies yourself.

Si je lance ensuite cette commande pour déployer grunt>=1:

npm install --save-dev "[email protected]>=1"

J’obtiens ces erreurs:

npm WARN [email protected] requires a peer of [email protected]~0.4.1 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of [email protected]~0.4.1 but none is installed. You must install peer dependencies yourself.

C’est un peu le serpent qui se mange la queue.
Mon fichier package.json est configuré comme ceci:

{
"name": "docdokuplm",
"private": true,
"description": "Web based application for DocDokuPLM server",
"version": "1.1.0",
"devDependencies": {
"bower": "~1.8.0",
"casperjs": "~1.1.3",
"connect-livereload": "~0.3.2",
"debug": "^4.1.1",
"del": "~1.2.0",
"grunt": "^1.1.0",
"grunt-cli": "^1.2.0",
"grunt-connect-proxy": "~0.2.0",
"grunt-contrib-clean": "~1.0.0",
"grunt-contrib-compress": "~1.3.0",
"grunt-contrib-concat": "~1.0.1",
"grunt-contrib-connect": "^1.0.2",
"grunt-contrib-copy": "~1.0.0",
"grunt-contrib-cssmin": "^3.0.0",
"grunt-contrib-htmlmin": "~2.4.0",
"grunt-contrib-jshint": "~1.1.0",
"grunt-contrib-jst": "~1.0.0",
"grunt-contrib-less": "~2.0.0",
"grunt-contrib-requirejs": "~1.0.0",
"grunt-contrib-uglify": "~2.0.0",
"grunt-contrib-watch": "~1.1.0",
"grunt-execute": "~0.2.2",
"grunt-rev": "~0.1.0",
"grunt-text-replace": "^0.4.0",
"grunt-usemin": "~3.1.1",
"jit-grunt": "~0.10.0",
"jshint-stylish": "~0.1.5",
"load-grunt-tasks": "~4.0.0",
"serve-static": "^1.13.2",
"time-grunt": "~0.2.10",
"underscore": "~1.7.0",
"uuid": "~3.0.1",
"xml2js": "~0.4.9",
"yargs": "^15.3.1"
},
"engines": {
"node": ">=0.10.0"
},
"scripts": {
"preclean": "npm install",
"prebuild": "npm install",
"predev": "npm install",
"prevalidate": "npm install",
"postinstall": "bower install",
"clean": "grunt clean",
"build": "grunt build",
"dist": "grunt serve:dist",
"dev": "grunt serve",
"validate": "grunt jshint"
},
"dependencies": {
"http-proxy": "^1.18.1",
"lodash": "^4.17.15",
"lodash.update": "^4.10.2"
}
}

Auriez vous quelques idées pour débloquer cette situation ?

1 J'aime
Human Coders - Le centre de formation recommandé par les développeur·se·s pour les développeur·se·s